Opened 5 years ago

Closed 5 years ago

#988 closed defect (fixed)

'spSetPieceCollisionData' (invalid piece)

Reported by: beherith Owned by: Bluestone
Priority: major Milestone: BAR Beta release
Component: BAR Version:
Keywords: Cc:

Description

Did I read something about piece indexing now being 0 based instead of 1 based and could this be the cause?

[f=0024225] Error: LuaRules::RunCallIn: error = 2, GameFrame, [Internal Lua error: Call failure] [string "LuaRules/Gadgets/unit_dynamic_collision_vol..."]:238: bad argument #2 to 'spSetPieceCollisionData' (invalid piece) stack traceback:

[C]: in function 'spSetPieceCollisionData' [string "LuaRules/Gadgets/unit_dynamic_collision_vol..."]:238: in function 'GameFrame' [string "LuaRules/gadgets.lua"]:839: in function <[string "LuaRules/gadgets.lua"]:837> (tail call): ?

Change History (5)

comment:1 by beherith, 5 years ago

duplicate of #975

comment:2 by Bluestone, 5 years ago

Owner: set to Bluestone

Yes, I'll deal with it, but it means moving BAR on to Spring 101 and not using 100 anymore; are ready to do that?

comment:3 by beherith, 5 years ago

Ive been on develop anyway, but ill look at wether there are any more breaking changes

EDIT: After looking through https://github.com/spring/spring/blob/develop/doc/changelog.txt and grepping bar source I dont see more conflicts.

Last edited 5 years ago by beherith (previous) (diff)

comment:4 by Bluestone, 5 years ago

There's bound to be a few, but this is the only one I can think of without reading stuff.

comment:5 by Bluestone, 5 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.