Opened 5 years ago

Closed 4 years ago

#941 closed defect (wontfix)

endgame bug: all dead - game is not ended

Reported by: Decay Owned by:
Priority: major Milestone:
Component: BA trunk Version:
Keywords: Cc:

Description

Change History (3)

comment:1 by Decay, 5 years ago

watching replay and the code... they had 3 teams :-) just take a look at the startboxes just at the beginning of the game one of the teams is: isGaia: true and hasLeader: false and it had no units from the start

comment:2 by Bluestone, 5 years ago

*Every* game has a Gaia team. It's part of the design of Spring - it's an uncontrolled team with no associated ally team that sits in the background. It's for game devs to use, for example one possible implementation of walls (that is not suited to BA) is that they could be units owned by gaia.

The game end gadget knows about Gaia - that's not the cause.

Last edited 5 years ago by Bluestone (previous) (diff)

comment:3 by Bluestone, 4 years ago

Resolution: wontfix
Status: newclosed

cause is zombie planes

Note: See TracTickets for help on using tickets.