Opened 5 years ago

Closed 5 years ago

#887 closed defect (duplicate)

Balanced Annihilation test-3709: [SetUnitTarget()]: unit tried to attack itself ()

Reported by: abma Owned by:
Priority: major Milestone:
Component: BA trunk Version:
Keywords: Cc:

Description

[f=0050300] Error: LuaRules::RunCallIn: error = 2, UnitDestroyed, [Internal Lua error: Call failure] [string "LuaRules/Gadgets/unit_target_on_the_move.lu..."]:264: [SetUnitTarget()]: unit tried to attack itself stack traceback:

[C]: in function 'spSetUnitTarget' [string "LuaRules/Gadgets/unit_target_on_the_move.lu..."]:264: in function 'removeUnit' [string "LuaRules/Gadgets/unit_target_on_the_move.lu..."]:325: in function 'UnitDestroyed' [string "LuaRules/gadgets.lua"]:1257: in function <[string "LuaRules/gadgets.lua"]:1254> (tail call): ?

Change History (3)

comment:1 by abma, 5 years ago

happens when running demo from here: https://springrts.com/mantis/view.php?id=4852

in a debug build.

comment:3 by Bluestone, 5 years ago

Resolution: duplicate
Status: newclosed

update your ba-test! duplicate of #886

Note: See TracTickets for help on using tickets.