Opened 6 years ago

Closed 5 years ago

#803 closed engine bug (fixed)

light flashes are too big

Reported by: Bluestone Owned by:
Priority: major Milestone:
Component: BAR Version:
Keywords: Cc:

Description

see screenshot, imo could reduce their size/falloff by a factor of 10-20

Attachments (1)

screen00168.png (4.4 MB ) - added by Bluestone 6 years ago.

Change History (13)

by Bluestone, 6 years ago

Attachment: screen00168.png added

comment:1 by beherith, 6 years ago

too big or TOO AWESOM? jk

comment:2 by Bluestone, 6 years ago

I did wonder if it might be worth taking some epic screenshots with it like this to use for load pictures :)

comment:3 by beherith, 6 years ago

Better now?

comment:4 by Bluestone, 6 years ago

I think the green and red ones could still be toned down quite a bit, but the blue ones (which are much paler, see e.g. armanni or beamer) are now good.

Spotted something extra: the blue laser of cordoom and armmanni seem to be missing the light effect.

comment:5 by anonymous, 6 years ago

Thats very odd, because during testing, i usually test with cordoom. Agreed on the green and red

comment:7 by Bluestone, 6 years ago

Type: defectengine bug

comment:8 by Bluestone, 6 years ago

Milestone: BAR Beta release

comment:9 by Bluestone, 6 years ago

hotfix: [3680]

But there is an additional bug here; when two beam projectiles have the same source/end loc, the light is too bright. See ddm.

Last edited 6 years ago by Bluestone (previous) (diff)

comment:10 by Jalmari Ikävalko, 5 years ago

Heya,

I toyed around with this today. To me, the brightness doesn't seem particularly problematic really, at least not with cordoom. However, I believe that I found the root cause; Firstly, the big laser shot of DDM has a very high flashAlpha and all the lasers of DDM have no alpha component defined for their colors. This leads to default alpha of 1.0 I believe. Why this is problematic, is due to the blend func used by CEG: https://springrts.com/wiki/CEG:Miscellaneous (under "Blending")

I put in lower alphas and very slightly reduced the particle sizes for DDM related effects. If the direction seen is a better one and the problem is fixed, please let me know and I'll do similar changes to other laser/explosion effects. It's mostly the super-high alphas that seem to cause the big stacking of multiple light effects.

/gamedata/explosions/ca_laser_mod.tdf diff: http://pastebin.com/hm5vrQ3P /gamedata/explosions/explosions.tdf diff: http://pastebin.com/CH4mpFwA

For convenience, here are also the full files: ca_laser_mod.tdf: http://koti.kapsi.fi/tzaeru/ca_laser_mod.tdf explosions.tdf: http://koti.kapsi.fi/tzaeru/explosions.tdf

and patch file, just to be complete: http://koti.kapsi.fi/tzaeru/

tzaeru / tzaeru@…

comment:11 by Jalmari Ikävalko, 5 years ago

I'm the king of fucking my posts up! :D

The patch file url: http://koti.kapsi.fi/tzaeru/explosions.patch

tzaeru / tzaeru@…

comment:12 by Bluestone, 5 years ago

Milestone: BAR Beta release
Resolution: fixed
Status: newclosed

(hot)fixed by [3906]

Note: See TracTickets for help on using tickets.