Opened 6 years ago

Closed 6 years ago

#722 closed defect (fixed)

Deferred rendering interferes with lups (-> update lups)

Reported by: Floris Owned by: beherith
Priority: minor Milestone:
Component: BAR Version:
Keywords: Cc:

Description

Fire Dgun -> com-nametag renders black + healthbars too, and much other things.

Attachments (1)

screen00007.jpg (205.2 KB ) - added by Floris 6 years ago.

Download all attachments as: .zip

Change History (11)

by Floris, 6 years ago

Attachment: screen00007.jpg added

comment:1 by Bluestone, 6 years ago

cant reproduce, attach infolog & test with luarules/luaui/various widgets disabled (using latest engine)

Last edited 6 years ago by Bluestone (previous) (diff)

comment:2 by Bluestone, 6 years ago

is this a duplicate of #633

-> explain why you think deferred rendering is now involved

Last edited 6 years ago by Bluestone (previous) (diff)

comment:3 by Bluestone, 6 years ago

also, "much other things" refers to what?

comment:4 by Floris, 6 years ago

some other widgets that draw icons.

Only thing I have to do to prevent it from happening is setting the 2 deferred cfg settings to 0.

Maybe it only happens in combination with other settings, and thats why it wont happen at your setup.

I also have these cfg settings: http://pastebin.com/VceLgSPx

Last edited 6 years ago by Floris (previous) (diff)

comment:5 by beherith, 6 years ago

Owner: set to beherith

Happens to me too, ill get around to fixing it

comment:6 by Bluestone, 6 years ago

I reproduced this & here's the results:

Key to reproducing it was
(1) AllowDeferredMapRendering on (AllowDeferredModelRendering was not involved)
(2) Lups enabled and a unit that that uses distortion drawn onscreen
I think that no other part of luaui/luarules is involved. BA/BAR lups are identical except for their configs.

It can be fixed by taking away either of the above - I bisected within lups and discovered that line 164 of distortionfbo.lua is responsible. It reads

  glTexture(3,"$map_gbuffer_zvaltex"); 

I expected that this line was drawing the map part of the lups distortion effect, but am slightly unsure because as far as I can tell commenting it out has no effect at all (except fixing the bug) on what distortion gets drawn (Maybe we are not using the map part of lups distortion at all?).

Last edited 6 years ago by Bluestone (previous) (diff)

comment:7 by Bluestone, 6 years ago

This is almost certainly caused by our Lups being out of date - see https://github.com/jk3064/lups/blob/master/lups/ParticleClasses/distortionFBO.lua#L154

comment:8 by Bluestone, 6 years ago

[3013] is the appropriate workaround, proper fix i guess is updating lups but didn't want to do that without finding out how much custom stuff we have inside lups (beyond config files).

comment:9 by Bluestone, 6 years ago

Priority: majorminor
Summary: Deferred rendering interferes with lupsDeferred rendering interferes with lups (-> update lups)

comment:10 by Bluestone, 6 years ago

Resolution: fixed
Status: newclosed

fixed by [3256]

Note: See TracTickets for help on using tickets.