Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#679 closed defect (invalid)

plasma bounces from friendly through own shield

Reported by: Floris Owned by:
Priority: major Milestone:
Component: BA trunk Version:
Keywords: Cc:

Description

Sometimes the plasma bounce can pierce through you own shield via a friendly.. ?

I ve experienced it a few times and it heavily sucks to see this happening.

Change History (5)

comment:1 by Floris, 6 years ago

I'm not entirely sure about the conditions though... Nor I can provide a demo yet.

Last edited 6 years ago by Floris (previous) (diff)

comment:2 by Bluestone, 6 years ago

Resolution: cantreproduce
Status: newclosed

Not entirely certain what you intend to mean is ally/enemy, but if you mean

"An enemy plasma shot can bounce off an ally shield and because of this it will then go straight through another ally shield instead of bouncing off."

No that shouldn't happen and in the test I just set up, it didn't, so a replay is required here; reopen ticket if you have one or if you meant something else.

Be aware that shields are just repulsive force fields, they are not perfect spheres off which everything always bounces. Shields will never repel plasma fired by ally units.

Last edited 6 years ago by Bluestone (previous) (diff)

comment:3 by Floris, 6 years ago

check this demo at 39 mins ingame time

http://replays.springrts.com/replay/2c0ecb53fa3ab5819c06bf441cdf4421/

Vulcan plasma bounced in the air, and lands vertically on top of and area with cover of 4 fully green shields...

This shouldnt happen

I recorded it, see: https://www.youtube.com/watch?v=_5HP1Ctayno (see the plasmaball of death at top-left base)

Last edited 6 years ago by Floris (previous) (diff)

comment:4 by Bluestone, 6 years ago

Resolution: cantreproduce
Status: closedreopened

reopened (replay attached)

comment:5 by Bluestone, 6 years ago

Resolution: invalid
Status: reopenedclosed

As far as I can tell, what happens there is that the projectile falls against your shield(s) from directly above, has sufficiently velocity to push them but not to bounce off them, so it ends up exploding resting against them. It explodes at a height of 19.9 elmos above the ground, and the explosion is enough to reach one of your Overseers and kill it. There is then a chain explosion from the Overseer, since it is surrounded by closely packed Nanos.

I have also checked with a short demo that projectiles inside/rebounding off one ally shield are repelled by other ally shields. I simply don't have time to run 39 minute demos more than once (if at all) - if you can reproduce the bug claimed above in a short demo with a NullAI then I'll look again.

So as far as I can tell there is no bug in that replay & it is "intended" behaviour, although I understand that viewed from above it isn't easy to see exactly what happens. If somehow there really is a bug but I can't find it, it's 99.99% an engine bug and belongs on mantis (BA does not control whether or not the shield repels invidual projectiles, it just sets a bitmask as to what weapon types are repelled).

Corbuzz/armvulc are intended to be somewhat unpredictable with potentially very damaging effects. It was absolutely my intention that shields would not be 100% guaranteed protection and that rebounding projectiles would be inconvenient to allies, although I hadn't envisaged this particular case of it.

For corbuzz/armvulc, I don't think there is a case for changing the edgeffectiveness of their projectiles on the basis that it is occasionally visually confusing to work out how they hit something. Possibly the CEG produced when they explode should be made larger, I'll look into that another time.

Last edited 6 years ago by Bluestone (previous) (diff)
Note: See TracTickets for help on using tickets.