Opened 7 years ago

Closed 6 years ago

#636 closed performance (fixed)

short hang on first gameframe

Reported by: Bluestone Owned by:
Priority: minor Milestone:
Component: BAR Version:
Keywords: Cc:

Description

always happens to me; at the moment of spawning there is a 1-3 second hang. i always thought it was the unit texture preloaded, but turns out it isn't that.

Change History (10)

comment:1 by beherith, 7 years ago

It actually IS caused by the arm atlas taking so long to load :(

comment:2 by Bluestone, 6 years ago

Type: defectperformance

comment:3 by Bluestone, 6 years ago

Possibly related - /luaui reload takes a few seconds to execute, but no idea why

comment:4 by beherith, 6 years ago

A widget does the preloading of the arm atlases, but I have no real idea how to get around this. Would using a gadget to pre-place an arm and a core commander before everything help in any way?

comment:5 by Bluestone, 6 years ago

Resolution: cantreproduce
Status: newclosed

Curiously, now I don't seem to have any lag at the moment of spawning and luaui reload is fine (takes only slightly longer than BA); I don't know what caused the change, if anyone else has the problem reopen the ticket.

comment:6 by beherith, 6 years ago

Resolution: cantreproduce
Status: closedreopened

Are you running bar off an ssd? because the culprit is loading 64mb of yextures for the first arm unit. If i launch bar multiple times in succession, this problem gets less noticable, becaise the os caches the files.

comment:7 by Bluestone, 6 years ago

Yes, I have SSD for all non data storage now - I could try running BAR off of of a plain HD to see if it makes any difference?

Last edited 6 years ago by Bluestone (previous) (diff)

comment:8 by Bluestone, 6 years ago

What about doing something slightly hacky in widget:Initialize that forces the atlas to be loaded? Like create a dummy cloaked unit & destroy one drawframe later.

Last edited 6 years ago by Bluestone (previous) (diff)

comment:9 by Bluestone, 6 years ago

Could others test if [2918] has fixed/helped the problem?

Last edited 6 years ago by Bluestone (previous) (diff)

comment:10 by Bluestone, 6 years ago

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.