Opened 7 years ago

Closed 6 years ago

#633 closed defect (worksforme)

gl.Unit() will stop render with lups fx in view

Reported by: Floris Owned by:
Priority: major Milestone:
Component: BAR Version:
Keywords: Cc:

Description

This is no problem in BA

Having in view: Cloacking, jet-thrusters, dgunning, ... ...will result in not rendering any gl.Unit() code.

both in DrawWorld and DrawWorldPreUnit

Attachments (2)

screen00224.jpg (73.7 KB ) - added by anonymous 6 years ago.
screen00100.png (2.8 MB ) - added by Bluestone 6 years ago.

Change History (9)

comment:1 by Bluestone, 7 years ago

Include an example line/piece of code that doesn't render but should? Can't test without that.

I guess you are writing widget code - in which case you should also test if you have the same problem after /luarules disable (which will turn off the custom unit shaders).

Last edited 7 years ago by Bluestone (previous) (diff)

comment:2 by Floris, 7 years ago

heathbars will render black-ish too (also the old healthbars version)

if i turn lups manager off there is no problem, unless something cloaks

Last edited 7 years ago by Floris (previous) (diff)

comment:3 by Bluestone, 6 years ago

can't reproduce (used spring 96.0.1-444 and bar-svn)

comment:4 by Bluestone, 6 years ago

still can't reproduce with 97.0.1-20

by anonymous, 6 years ago

Attachment: screen00224.jpg added

comment:5 by anonymous, 6 years ago

see commander nametags getting black aswell when something with lups is in view

comment:6 by Bluestone, 6 years ago

Not for me, see screenshot.

No idea what could cause this for you, sorry.

Last edited 6 years ago by Bluestone (previous) (diff)

by Bluestone, 6 years ago

Attachment: screen00100.png added

comment:7 by Bluestone, 6 years ago

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.