Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#632 closed defect (wontfix)

resigning before the game starts

Reported by: Floris Owned by:
Priority: minor Milestone:
Component: BA trunk Version:
Keywords: Cc:

Description

Resigning pregame (the spotpicking moment) will result in being unable to resign. console messages something about being unable to resign your team. After this you cant pick another spot either (while not-ready ofc).

Resigning after game started will result in an error message thinking you are already a spec.

Change History (5)

comment:1 by Bluestone, 9 years ago

What command are you using to resign before the game?

Resigning before the game starts is meant (intentionally) to be impossible, as a feature of the engine (https://github.com/spring/spring/commit/25807f7df9ce0c6463759e836b04df192cc2cbe0)

A replay of this (your own, not servers) would be useful.

Last edited 9 years ago by Bluestone (previous) (diff)

comment:2 by Bluestone, 9 years ago

Summary: pregame-resign is buggyresigning before the game starts

comment:3 by Floris, 9 years ago

just the regular shift+esc, then click resign.

i've searched for the replay, without success :(

comment:5 by Bluestone, 9 years ago

Resolution: wontfix
Status: newclosed

Can't reproduce what is claimed above, although oddly issueing /spectator in a single player game causes the game to start.

Feel free to reopen with a replay of the issue, can't do anything without that.

Last edited 9 years ago by Bluestone (previous) (diff)
Note: See TracTickets for help on using tickets.