Opened 8 years ago

Closed 8 years ago

#530 closed defect (fixed)

make AI startpos work with 'choose before game' startpoints

Reported by: Bluestone Owned by:
Priority: minor Milestone:
Component: BA trunk Version:
Keywords: Cc:

Description

pID in gadget:AllowStartPosition is 255 for AI -> tID and aID is nil

so need to disable start point guesser for 'choose before game' mode

to check: does coop mode work with choose before game?

Change History (3)

comment:1 by zoggop@…, 8 years ago

as well as disabling the start point guesser for 'choose before game' mode, cdoes the start point guesser gadget have access to the map's start locations? would be good first guesses

comment:2 by Bluestone, 8 years ago

Your request is a duplicate of #470 ;) Actually they would be bad guesses (at least, on their own) because they wouldn't take account of where players/AIs are already placed, but they are useful as a last resort e.g. when the metal map cannot be repesented as discrete spots.

Last edited 8 years ago by Bluestone (previous) (diff)

comment:3 by Bluestone, 8 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.