Opened 8 years ago

Closed 8 years ago

#525 closed defect (fixed)

gpu memleak on viewresize in distortionFBO

Reported by: beherith Owned by:
Priority: major Milestone:
Component: BA trunk Version:
Keywords: Cc:

Description

both in BAR and BA versions. Probably some FBO is retaining bindings of a texture.

Change History (9)

comment:1 by beherith, 8 years ago

To reproduce: watch gpu ram use with a tool like msi afterburner for nvidia. Have lups on, spawn a corfus in center of view. Mash windows key+left-right to trigger viewresizes, watch mem use grow fast.

comment:2 by Bluestone, 8 years ago

How fast does it leak? I guess since viewresizes are a rare thing to do, this never got detected before.

Last edited 8 years ago by Bluestone (previous) (diff)

comment:3 by beherith, 8 years ago

It leaks 10-20 mbytes on each view resize

comment:4 by beherith, 8 years ago

Bluestone, could you check if it leaks on your AMD gpu too? (If you have easy access to GPU-Z or similar software.)

comment:5 by Bluestone, 8 years ago

Will do, give me a couple of days. Do you think is a BA or engine issue? RedUI uses openGL pretty poorly so if it's BA then that would be my first guess.

Last edited 8 years ago by Bluestone (previous) (diff)

comment:6 by beherith, 8 years ago

Effects every mod that uses lups distortion (airjet, corfus, etc). I dont think anything else leaks, at least I didnt notice anything major.

comment:7 by Bluestone, 8 years ago

Yep, memleaks for me to, each resize leaks between 5 and 30mb.

comment:8 by Bluestone, 8 years ago

I guess we've confirmed this is an engine bug now?

comment:9 by Bluestone, 8 years ago

Resolution: fixed
Status: newclosed

iirc this was an engine bug that is now fixed

Note: See TracTickets for help on using tickets.