Opened 7 years ago

Closed 6 years ago

#467 closed enhancement (fixed)

LOS shader things TODO/notes

Reported by: beherith Owned by:
Priority: major Milestone:
Component: BAR Version:
Keywords: Cc:

Description

Some great ideas: Have the LOS shader fade in on game start (excellent!) Make the noise/darkening/saturation levels customizable in f11 view. Make the shader not shade outside of the map.

Change History (5)

comment:1 by beherith, 7 years ago

It really does not help with the f4 view, as that is desaturated too.

Also needed are sliders in the f11 UI to adjust the noisefactor, the desaturation and darken factors.

Also, deferred lights are still colored, they should also get the desat treatment

It currently does not work well with bloom, because bloom is applied before the LOS shading.

comment:2 by Bluestone, 7 years ago

appears wrong for specs - nothing shaded when zoomed out, everything shaded when zoomed in (imo better that nothing gets shaded for specs unless they are in specfullview)

comment:3 by beherith, 7 years ago

I cant reproduce the nothing shaded/everything shaded thing, Could you please post a screenie.

comment:4 by beherith, 7 years ago

Fixed los shader for specs in fullview.

comment:5 by beherith, 6 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.