Opened 8 years ago

Closed 6 years ago

#119 closed engine bug (worksforme)

age old ati issues

Reported by: Bluestone Owned by: somebody
Priority: minor Milestone:
Component: BA trunk Version:
Keywords: Cc:

Description (last modified by Bluestone)

list of widgets with ati issues, mostly disabled

(originally about highlight unit bugs with pointsize)

Attachments (1)

screen00000.png (2.0 MB ) - added by Bluestone 8 years ago.

Change History (17)

comment:1 by beherith, 8 years ago

Got a screenshot? Who has this bug? prolly ati related.

comment:2 by Bluestone, 8 years ago

I'll turn the widget on and make a screenshot next time I see it. I know quite a few others have had the same bug, because I've been asked which widget to disable more than once.

I have another bug with highlight unit - sometimes it draws coloured spheres onto every corner of the model. I don't know what triggers either bug but I agree probably ATI related.

Last edited 8 years ago by Bluestone (previous) (diff)

comment:3 by Bluestone, 8 years ago

It's this: http://springrts.com/phpbb/viewtopic.php?f=11&t=27775.

Seem it happens because ATI write drivers using the typewriter/monkey method.

by Bluestone, 8 years ago

Attachment: screen00000.png added

comment:4 by Bluestone, 8 years ago

Some people (but many less, maybe because its disabled by default) report a similar issue with highlight ally selected units

comment:5 by Bluestone, 8 years ago

red minimap has something similar as well

comment:7 by beherith, 7 years ago

Resolution: fixed
Status: newclosed

Engine bug, marked as fixed.

comment:8 by Bluestone, 7 years ago

It's defainately not fixed, although it's not as bad as it used to be. Afaik the only 'fix' for this was "don't use gl.Pointsize" because the combination of spring & ATI cards have some bug with it.

Reopening because I don't want to lose the list of related stuff.

Last edited 7 years ago by Bluestone (previous) (diff)

comment:9 by Bluestone, 7 years ago

Priority: majorminor
Resolution: fixed
Status: closedreopened

comment:10 by Bluestone, 7 years ago

Component: component1BA trunk

comment:11 by Bluestone, 7 years ago

Type: defectengine bug

comment:12 by Bluestone, 6 years ago

Description: modified (diff)
Summary: The highlight unit widget soemtimes changes half the screen blue/yellow and causes a short hang.age old ati issues

comment:13 by Bluestone, 6 years ago

Description: modified (diff)

the bar version of enemy_spotter may have inherited some of these problems from the xray shader coder added to it in [2547]

comment:14 by Bluestone, 6 years ago

Description: modified (diff)

comment:15 by Bluestone, 6 years ago

Some of this may actually be fixed now, in 97+git

Last edited 6 years ago by Bluestone (previous) (diff)

comment:16 by Bluestone, 6 years ago

Resolution: worksforme
Status: reopenedclosed

these issues are at least partially solved, or at least now different enough that there is no need to keep this ticket

Note: See TracTickets for help on using tickets.