Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1093 closed defect (fixed)

com name tags is too expensive

Reported by: Bluestone Owned by:
Priority: minor Milestone:
Component: BAR Version:
Keywords: Cc:

Description

it is *the* most expensive widget xD

Change History (2)

comment:1 by beherith, 6 years ago

Seriously? Is billboard that expensive or is it caused by other stuff in it?

comment:2 by Bluestone, 6 years ago

Resolution: fixed
Status: newclosed

it was caused by calling font:XXX inside glDrawFuncAtUnit, which was introduced with a wtf unhelpful commit msg in http://imolarpg.dyndns.org/trac/balatest/changeset/3470. the "performace improvement" of that commit is a 6-fold reduction in perf afaics.

taking the current code and instead translating with glPushMatrix cuts the cpu load by factor of ~6

i have very occasionally had issues where the cpu time used by this widget skyrockets when you turn CUS off, but it doesn't reproduce reliably and only happens after multiple luaui reloads afaics

aside from that, its cpu usage should be back to sanity after [5370]

Last edited 6 years ago by Bluestone (previous) (diff)
Note: See TracTickets for help on using tickets.