Opened 6 years ago

Closed 6 years ago

#1074 closed enhancement (fixed)

Bgu playerlist presents a large chili load

Reported by: beherith Owned by:
Priority: minor Milestone: BAR Beta release
Component: BAR Version:
Keywords: Cc:

Description

I tested with 8 bots, and found that bgu playerlist represents around 3ms load per draw frame.

Attachments (1)

_script - BAR DSDR 8SHARD.txt (3.1 KB ) - added by beherith 6 years ago.
8 shards on DSD (drag onto spring.exe to launch)

Download all attachments as: .zip

Change History (6)

comment:1 by Bluestone, 6 years ago

lua load (i.e. visible in widget profiler) or gfx card load (i.e. not visible in widget profiler)?

comment:2 by Bluestone, 6 years ago

also, was this before widget:GameStart? It has to do some polling for faction/substitutes, but once the game has started its Update load drops.

comment:3 by Bluestone, 6 years ago

Resolution: fixed
Status: newclosed

There is nothing actually wrong here - but it has to poll alot of information for updates and the rate needs to be set sensibly. So much info is involved that there has to be polling for at least some of it, although it does do a targeted update for the important cases.

It was every 0.2 secs, now its every 1 sec.

comment:4 by beherith, 6 years ago

Resolution: fixed
Status: closedreopened

Its unfortunately not caused by the widget updates itself. It just spawns so many controls it sends chili into a deathspiral:D

To reproduce, launch with this script (8 Shards on DSD with BAR $Version), enable widget profiler, watch frame rate and chili load in profiler as you activate and deactivate playerlist.

by beherith, 6 years ago

8 shards on DSD (drag onto spring.exe to launch)

comment:5 by Bluestone, 6 years ago

Resolution: fixed
Status: reopenedclosed

missing prevTimer=timer spammed Invalidate()

Note: See TracTickets for help on using tickets.