Opened 7 years ago

Closed 7 years ago

#1071 closed enhancement (fixed)

Should kbot wrecks have fallen over kbots, or is are the current standing ones OK?

Reported by: beherith Owned by:
Priority: major Milestone:
Component: BAR Version:
Keywords: Cc:

Description

I feel that it looks off for some units, but it will probably be a huge chunk of work to do them all manually...

Change History (6)

comment:1 by Bluestone, 7 years ago

I think its absolutely fine as it is.

Maybe the commander wrecks could be replaced by something thats "snapped during the explosion" in a couple of places, they can look a bit strange if the com explosions makes a crater and they are left not standing vertical.

edit: Or, could have a gadget which, if the angle of the ground after the explosion is too steep, makes an upright wreck likely to fall over. I could have a go at writing this if you like, I think it will need hacks.

Last edited 7 years ago by Bluestone (previous) (diff)

comment:2 by beherith, 7 years ago

Its maybe only a couple of hours of work to do the wreck models, but if you are interested in animating them in such a way, have a look at the tree feller gadget (as hacky as it gets, not recommended).

Though the best route might be to simulate them in some sort of ragdoll simulator, then save the drop animation into the killed() script.

I have experimented with anims in killed() before, and found it to have issues (like the unit is still a unit, just paralyzed while the killed() runs)

comment:3 by Bluestone, 7 years ago

It's probably enormously better since the recent changes (which, on the lua side, mean there is both UnitDestroyed and UnitRenderedDestroyed, and that units are still even able to receive orders while their killed() runs).

comment:4 by beherith, 7 years ago

Is them getting orders while killed() even a good thing? I cant think of anything they should do while dying, and im afraid it would even interfere with units still targeting them and wasting dps.

comment:5 by Bluestone, 7 years ago

Dead units receiving orders is not a good thing from our point of view - we should probably add a gadget to prevent it, although in practice it will make no difference since our killed()s are very quick - the issue is lengthy death animations which are used in some other games. But I think its now possible to add a shader to a unit while its in the process of dying, or to the fragments it leaves behind (or smth...) which it wasn't before.

I should add that I haven't actually tested this, I just read it in a commit msg.

I am not sure about targeting, but I imagine that part of the engine won't have changed.

Last edited 7 years ago by Bluestone (previous) (diff)

comment:6 by Bluestone, 7 years ago

Resolution: fixed
Status: newclosed

the new wrecks look great

Note: See TracTickets for help on using tickets.