Opened 8 years ago

Closed 8 years ago

#107 closed defect (wontfix)

mines can be built on top of one another

Reported by: Bluestone Owned by: somebody
Priority: major Milestone:
Component: component1 Version:
Keywords: Cc:

Description

:D

Change History (3)

comment:1 by Bluestone, 8 years ago

Summary: commandos automagically build mines next to something when they attack itmines can be built on top of one another

(For previous title - Opps. Commandos are supposed to build mines automagically.)

comment:2 by Bluestone, 8 years ago

[23:38:02] <[Fx]Bluestone> should we allow mines to be built one of top of another? [23:38:17] <[Fx]Bluestone> the tradeoff is that if we don't, units have to walk around their (tiny) yardmap [23:40:44] <DeadnightWarrior> it can give off the position of mine, as when your units start driving around the battlefield in an unusual fashion, you can expect either trenches, walls or mines [23:41:28] <DeadnightWarrior> as PFS secretly knows which areas are passable and which are not [23:42:45] <DeadnightWarrior> you could make an invisible wall that way though, as unit would try to drive around a wall of mines, while you can't see them like regular walls [23:44:13] <DeadnightWarrior> mine stacking is the same bug as being able to build a small structure inside an open factory [23:44:44] <[Fx]Bluestone> yeah hmm [23:44:51] <[Fx]Bluestone> i don't think there is a neat solution to this :( [23:45:08] <DeadnightWarrior> it's cause by engine looking at the ground occupation map for building placement, regardelss of the actual yardmap usage [23:45:14] <DeadnightWarrior> *caused [23:45:15] <[Fx]Bluestone> if you set mines on hold fire it really would be an invisible wall

comment:3 by beherith, 8 years ago

Resolution: wontfix
Status: newclosed

Too many issues with a workaround -> classifying multi mines as a feature, not a bug. Closing.

Note: See TracTickets for help on using tickets.