Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1059 closed defect (fixed)

the map goes black when i order to build a wind turbine

Reported by: Bluestone Owned by: beherith
Priority: major Milestone: BAR Beta release
Component: BAR Version:
Keywords: Cc:

Description (last modified by Bluestone)

for about 1 sec just after i give the build order

Attachments (1)

screen00675.jpg (100.7 KB ) - added by Bluestone 6 years ago.

Download all attachments as: .zip

Change History (19)

by Bluestone, 6 years ago

Attachment: screen00675.jpg added

comment:1 by Bluestone, 6 years ago

map was porky islands, which has nothing special about it afaik

comment:2 by Bluestone, 6 years ago

can't find any other units that cause it

comment:3 by Bluestone, 6 years ago

deferred rendering widget is responsible!

comment:4 by Bluestone, 6 years ago

Description: modified (diff)

comment:5 by Bluestone, 6 years ago

Owner: set to beherith

comment:6 by Bluestone, 6 years ago

[11:24:26] <[teh]Beherith[PiRO]> could you try reverting 5126?

comment:7 by beherith, 6 years ago

Attempted fix in [5134]

comment:8 by Bluestone, 6 years ago

It still happens.

comment:9 by Bluestone, 6 years ago

I've now had it happen with other units too - not sure quite what the trigger is.

comment:10 by beherith, 6 years ago

It is definitely caused by the unit drawing part of inf_commands_fx. Ive spent quite a bit of time trying to debug it, short of whipping out geDebugger.

I cant find the root of the issue, even though nothing is actually drawn by the useshader portion of it. (nothing actually shows up, something may still be going on)

For now I would recommend just axing this part of the widget :(

Its wierd that corwin reproducibly triggers it, yet not many other units do so...

Last edited 6 years ago by beherith (previous) (diff)

comment:11 by Bluestone, 6 years ago

It must be something caused by interaction between the commands fx shader and the deferred rendering shader - for me disabling either of the two fixes the problem.

comment:12 by Bluestone, 6 years ago

[09:53:20] <[Fx]Bluestone> i think if you can't see what's wrong, its entirely legitimate to ask kloot for help, since its his removal that means it has to be now done with a shader + seems clear that no one else knows how to do it either [09:53:52] <[Fx]Bluestone> it might well be another partly engine bug too

Last edited 6 years ago by Bluestone (previous) (diff)

comment:13 by beherith, 6 years ago

I fucking give up. Only corwin triggers it. There is no possible explanation that I can think of. Even though we arent setting the teamcolor uniforms correctly, but that is beyond the issue here.

UnitShape breaks all map rendering (with corwin!)

Important: sometimes, after a while, I cant reproduce the bug. /luaui reset always brings it back :D

Last edited 6 years ago by beherith (previous) (diff)

comment:14 by Bluestone, 6 years ago

Kloot already knew the answer - https://springrts.com/mantis/view.php?id=5184

Also, it appears to have been my fault...

Last edited 6 years ago by Bluestone (previous) (diff)

comment:15 by Bluestone, 6 years ago

In [5300], I think you should instead check if the shader is nil and delete if not (I guess [5300] will have broken smth minor with luaui reload). After that, should be able to close this?

comment:16 by beherith, 6 years ago

Shader variable was not even localized. If I localize shader, and do a nil check before deletion, the bug returns. The shader is recreated anyway for luaui reload, it should be fine.

comment:17 by Bluestone, 6 years ago

Resolution: fixed
Status: newclosed

comment:18 by Bluestone, 6 years ago

n2s, might still be an issue with option changes, which also calls UpdateEverything()

Note: See TracTickets for help on using tickets.