Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1000 closed defect (fixed)

sInfo crash with spring 101 or above

Reported by: nixtux Owned by:
Priority: major Milestone:
Component: BAR Version:
Keywords: Cc:

Description

steps to reproduce /cheat /globallos /give 1 corcom 1

Error message [f=0000106] cheat [f=0000107] Cheating is enabled! [f=0000195] globallos [f=0000195] [GlobalLosActionExecutor] global LOS toggled for all allyteams [f=0000419] give 1 corcom [f=0000419] [GiveUnits] spawned 1 corcom unit(s) for team 0 [f=0000531] give 1 corcom 1 [f=0000531] [GiveUnits] spawned 1 corcom unit(s) for team 1 [f=0000541] [Chili] Error: in Selection info:progressbar3 : [string "libs/chili/headers/skinutils.lua"]:740: bad argument #5 to 'ClipPlane' (number expected, got NAN (check your code for div0)) [f=0000541] [Chili] Error: stacktrace:

[C]: in ClipPlane [string "libs/chili/headers/skinutils.lua"]:740: in DrawControl [string "libs/chili/controls/control.lua"]:1300: in ? [string "libs/chili/controls/object.lua"]:693: in fnc ... (23 calls) (tail call): in ? [string "libs/chili/controls/control.lua"]:1328: in DrawChildren

[f=0000541] [Chili] Error: Removed widget: Selection info [f=0000541] Error: DrawScreen: OpenGL stack check error, matrix mode = GL_MODELVIEW, depth = 7, please make sure to pop all matrices before end

Change History (4)

comment:1 by Bluestone, 5 years ago

I can't reproduce this. But please try again and copy the error message, which after [4791] should now tell me which control is causing it.

It would be useful to know how many units were on the map when you triggered the bug, and how many units you had selected before and immediately after you give

Last edited 5 years ago by Bluestone (previous) (diff)

comment:2 by Bluestone, 5 years ago

[Chili] Error: in Selection info:unitHealth : [string "libs/chili/headers/skinutils.lua"]:740: bad argument #5 to 'ClipPlane' (number expected, got NAN (check your code for div0))

comment:3 by Bluestone, 5 years ago

Resolution: fixed
Status: newclosed

(probably)

comment:4 by nixtux, 5 years ago

I can confirm that it is now fixed

Note: See TracTickets for help on using tickets.